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INTRODUCTION TO EXCEL
Microsoft Excel is a powerful spreadsheet software
developed by Microsoft, part of the Microsoft Office
suite (now also available as part of Microsoft 365).
It is used for organizing, analyzing, and visualizing data
in tabular form. 
Excel allows users to create spreadsheets with multiple
worksheets, perform complex calculations, generate
charts and graphs, and automate tasks through
macros and formulas.

FEATURES OF EXCEL
1. Workbooks and Worksheets:  

Excel organizes data in workbooks, which contain
multiple worksheets. 
Each worksheet is made up of rows and columns
forming a grid where data is entered.

2. Formulas and Functions: 
Excel supports a wide range of formulas and functions
to perform calculations on data

3. Data Analysis Tools: 
Excel provides tools such as PivotTables, Conditional
Formatting, and Data Validation to analyze and
interpret data effectively.
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4. Charts and Graphs:
 Excel can generate various types of charts (e.g., bar, line,
pie charts) to visually represent data and trends, making
it easier to understand and present.

5. Automation and Macros: 
With VBA (Visual Basic for Applications),

      Excel allows users to automate repetitive tasks by
      creatingmacros—scripts that run a series of commands
      automatically.
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FUNCTIONS IN EXCEL
In Excel, functions are predefined formulas that allow you
to perform various calculations and operations easily.

1. MATHEMATICAL FUNCTIONS
SUM: Adds up a range of cells.
      Ex: =SUM(A1:A5)

AVERAGE: Calculates the average of a range of cells.
       Ex: =AVERAGE(A5:A10)

COUNT: Counts the number of cells containing numbers.
       Ex: =COUNT(A10:A14)

MIN: Finds the smallest value in a range.
       Ex: = MIN(A15:A18)

MAX: Finds the largest value in a range.
       Ex: =MAX(A20:A30)

MOD: Returns the remainder after division.
       Ex: =MOD(A14:A19)

ROUND: Rounds a number to a specified number of
decimal places.
       Ex: =ROUND(A1:A10)
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2.TEXT  FUNCTIONS
CONCATENATE: Combines multiple text strings into one.
      Ex: =CONCATENATE (A1, &quot; &quot;, B1)

LEFT: Extracts a specified number of characters from the
left of a text string.
       Ex:- =LEFT(A1, 5)

RIGHT: Extracts a specified number of characters from the
right of a text string.
       Ex: - =RIGHT(A1, 3)

UPPER: Converts text to uppercase.
         Ex: - =UPPER(A1)

LOWER: Converts text to lowercase.
         Ex: - =UPPER(A1)

FIND: locate text within a string.
      Ex:FIND(&quot;R&quot;,&quot;ANJIRAJU&quot;)//
        returns 5

REPLACE: Replace existing text using a position
      Ex:=REPLACE(&quot;XYZ123&quot;,4,3,&quot; 
       ABC&quot;)// returns &quot;XYZABC&quot;

TRIM: Remove extra spaces from text.
       Ex: =TRIM (&quot; ANJIRAJU. &quot;) // returns
         &quot;ANJIRAJU.&quot;

LEN: count the number of characters in a string.
       Ex: =LEN(&quot;ANJIRAJU &quot;) // returns 8
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3.LOGICAL  FUNCTIONS
IF: Performs a conditional test and returns one value if true
and another if false.
       Ex: -=IF(A1&gt;10, &quot;Yes&quot;, &quot;No&quot;)

AND: Returns TRUE if all conditions are true.
      Ex: - =AND(A1&gt;5, B1&lt;10)

OR: Returns TRUE if at least one condition is true.
       Ex: - =OR(A1&gt;5, B1&lt;10)

NOT: Reverses the logic of its argument (TRUE becomes
FALSE, and FALSE becomes TRUE).
       Ex: - =NOT(A1&gt;10)

SWITCH: - The Excel SWITCH function compares one value
against a list of values and returns a result corresponding
to the first match found. When no match is found, SWITCH
can return an optional default value.
      Ex: - = SWITCH
      (TRUE,A1&gt;=1000,&quot;Gold&quot;,A1&gt;=500,
      &quot;Silver&quot;,&quot;Bronze&quot;)
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4. DATE &AMP; TIME FUNCTIONS
TODAY: Returns the current date. Only date is display.
      Ex: - =TODAY()

NOW: Returns the current date and time.
       Ex: - NOW()

DATE: Returns the date based on year, month, and day
inputs.
       Ex: - =DATE(2024, 12, 20)

YEAR: Extracts the year from a date.
      Ex: - = YEAR (&quot;23-Aug-2012&quot;) // returns 2012

MONTH: Extracts the month from a date.
        Ex: - = MONTH (&quot;23-Aug-2012&quot;) // returns 8

DAY: Extracts the day from a date.
       Ex: - = DAY (2022-11-25) // returns 11

DATEDIF: - Get days, months, or years between two dates
      Ex: - =DATEDIF(&quot;1-Jan2022&quot;,&quot;1-Mar
        2024&quot;,&quot;y&quot;) // returns 2 Years
        =DATEDIF(&quot;1-Jan-2022&quot;,&quot;1-Mar
        2024&quot;,&quot;m&quot;) // returns 26 Months
        =DATEDIF(&quot;1-Jan-2022&quot;,&quot;1-Mar
        2024&quot;,&quot;d&quot;)// returns 790 Days
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5. LOOKUP &AMP; REFERENCE FUNCTIONS
VLOOKUP:- Searches for a value in the first column of a
table and returns a value from another column in the
same row.
       EX:

HLOOKUP: - Like VLOOKUP but searches horizontally in the
first row.
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 XLOOKUP: - XLOOKUP is a modern replacement for the
VLOOKUP function. It is a flexible and versatile function that
can be used in a wide variety of situations. XLOOKUP can
find values in vertical or horizontal ranges, can
perform approximate and exact matches, and supports
wildcards (* ?) for partial matches.

INDEX: Returns the value of a cell in a specific row and
column ofa range.
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MATCH: Searches for a value in a range and returns its
relativeposition.
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6. STATISTICAL FUNCTIONS
MEDIAN: Returns the median of a range of numbers.

STDEV: Estimates the standard deviation based on a
sample.

MODE: 
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PMT: Calculates the payment for a loan based on constant
payments and a constant interest rate.

 FV: Calculates the future value of an investment based on
constant payments and a constant interest rate.

7. FINANCIAL FUNCTIONS
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8. INFORMATION FUNCTIONS
ISBLANK: Checks whether a cell is empty.

ISNUMBER: Checks whether a value is a number.



ISERROR: Checks for errors in a formula.
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DATA MANIPULATION IN EXCEL
Data manipulation in Excel involves various techniques
to organize, analyze, and transform data to make it
more usable and insightful. 
It can include sorting, filtering, formatting, combining
data, and using formulas to transform and summarize
data.

1. SORTING DATA
Ascending or Descending Order: Sorting data helps
organize it in a meaningful order, either alphabetically or
numerically.

How to Sort:
Select the range of data.
Go to the Data tab.
Use the Sort A to Z (ascending) or Sort Z to A
(descending)buttons.

Custom Sorting: If you want a custom order (e.g., days of
the week), you can set custom sorting.
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AutoFilter: Filters data to display only the rows that meet
certain criteria.

How to Filter:
Select your data range (including headers).
Go to the Data tab and click on Filter.
Use the dropdowns in each column header to set your
filter conditions.

You can filter by:
Text (e.g., contains, starts with)
Numbers (e.g., greater than, less than)
Dates (e.g., before, after a specific date)

Advanced Filter: More complex filtering, where you can
use multiple criteria and even extract data to another
location.

How to Use:
Go to Data &gt; Advanced (in the Sort &amp; Filter
group) and configure the filter criteria.

2. FILTERING DATA

Analytics Career Connect Wasim Patwari



Highlighting Data: You can automatically apply different
formatting to data based on certain conditions.
How to Apply:

Select your data range.
Go to Home tab &gt; Conditional Formatting.
Choose from options like Highlight Cell Rules, Data Bars,
Colour Scales, etc.

Example: Highlight cells that are greater than a certain
value or have duplicate values.

3. USING CONDITIONAL FORMATTING

4. DATA VALIDATION
Setting Data Validation: Ensure that only valid data is
entered into cells (e.g., only numbers, dates, or specific
choices).
 How to Set:

Select the range.
Go to Data tab &gt; Data Validation.
Define the type of data allowed (e.g., whole
numbers,dates, or a custom rule).

Drop-Down Lists: Allow users to select from predefined
values.
Example: Go to Data Validation, select List, and provide a
range ormanually input the options.
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5. PIVOT TABLES FOR DATA SUMMARY
Create Pivot Tables: Pivot Tables are a powerful way to
summarize and manipulate large sets of data. You can
group, filter, and aggregate
data dynamically.
How to Create a Pivot Table:

Select your data range.
Go to Insert tab &gt; PivotTable.
Drag and drop fields into rows, columns, values, and
filters to organize and summarize your data.

 Example: Summarize sales by region and product.

6. TEXT-TO-COLUMNS
Split Data: Split data in a column into multiple columns,
such as splitting a full name into first and last names.
 How to Set:

Select the column.
Go to Data tab &gt; Text to Columns.
Choose either Delimited (if there is a specific separator
likecommas or spaces) or Fixed width (split based on
specificpositions).

7. REMOVING DUPLICATES
Remove Duplicates: Clean up your data by removing
duplicate entries.
 How to Remove:

Select your data range.
Go to Data tab &gt; Remove Duplicates.
Choose which columns to check for duplicates.
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8. CONSOLIDATING DATA
Consolidate Data from Multiple Sheets: Combine data
from multiple ranges or sheets into one summary table.
How to Consolidate:

Go to Data tab &gt; Consolidate.
Choose the function (e.g., sum, average) and the
ranges to

consolidate.
Using Formulas: You can also consolidate data manually
using formulas like SUMIF, VLOOKUP, INDEX, etc.

9. GROUPING AND UNGROUPING DATA
Group Data: You can group rows or columns to collapse or
expand data for better organization.
 How to Group:

Select the rows or columns.
Go to Data tab &gt; Group.

Ungroup Data: To expand the grouped data, select the
grouped rows/columns, and click Ungroup.

10. CONVERTING DATA TYPES
Convert Text to Numbers: Sometimes numbers stored as
text need to be converted to actual numbers for
calculations.
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Data visualization in Excel allows you to present data in a
graphical format, making it easier to understand patterns,
trends, and insights. Excel offers a wide range of
visualization tools, from simple charts to complex
dashboards.

Excel provides a variety of chart types to help visualize your
data. To create a chart, follow these general steps:

Select your data (including headers).
Go to the Insert tab on the ribbon.
Choose a chart type from the Charts section.

DATA VISUALIZATION

Common Chart Types in Excel:

Column Chart: Useful for comparing data across
categories (e.g., sales by month).

Example: A bar chart showing sales in different regions.
How to Create: Insert &gt; Bar or Column Chart &gt;
Clustered Column.

Line Chart: Ideal for displaying trends over time, such
as sales growth or stock prices.

Example: A line chart showing revenue over several
months.
How to Create: Insert &gt; Line Chart.

1.CHARTS IN EXCEL
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Pie Chart: Best for showing proportions or percentages
of a whole, like market share.

Example: A pie chart showing the distribution of sales
across different product categories.
How to Create: Insert &gt; Pie Chart.

Scatter Plot: Displays relationships between two
variables. Often used for scientific or statistical data.

 Example: A scatter plot showing the relationship between
advertising spending and sales.
 How to Create: Insert &gt; Scatter (X, Y) Chart.

Area Chart: Used to show the magnitude of change
over time andvisualize cumulative totals.

Example: Showing the cumulative sales growth of a
company over time.
How to Create: Insert &gt; Area Chart.

Doughnut Chart: Similar to a pie chart but with a hole in
the center, often used for showing parts of a whole with
additional data.

How to Create: Insert &gt; Doughnut Chart.

Radar Chart: Useful for displaying multivariate data
with three or more variables, often used for comparing
performance across multiple categories.

How to Create: Insert &gt; Radar Chart
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Once you’ve created a chart, you can customize it to make it
more informative and visually appealing:

Chart Title: Click on the chart title to edit it, providing a clear
description of what the chart represents.
 Legend: Display a legend to help identify different data
series in the chart.
Axis Titles: Add axis titles to clarify what each axis
represents (e.g., Time, Revenue, etc.).
Data Labels: Display actual values on the chart to make the
data easier to interpret.

      Right-click the data series &gt; Add Data Labels.
Change Colors: Use different colors to distinguish between
categories or data series.

      Right-click on a series &gt; Format Data Series
      &gt; Fill.

2. FORMATTING CHARTS

Heat Maps: Use conditional formatting to create heat maps,
where cells change colour based on their values.

 How to Apply:
Select your data range.
Go to Home tab &gt; Conditional Formatting &gt; Colour
Scales (choose a colour gradient)

Data Bars: Represent values as horizontal bars within cells.
How to Apply:
Select your range &gt; Conditional Formatting &gt; Data Bars.

Icon Sets: Display icons based on the value of the cell (e.g.,
traffic light icons for performance).

How to Apply:
Select your range &gt; Conditional Formatting &gt; Icon Sets..

3. CONDITIONAL FORMATTING FOR VISUALIZATION
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4. SPARKLINES
Sparklines are mini charts that fit within a single cell to give
a quick visual representation of data trends.
How to Create:

Select a cell where you want to add a sparklin.
 Go to Insert &gt; Sparklines (Line, Column, or Win/Loss).
 Define the data range for the sparkline.

5. PIVOT CHARTS
Pivot charts are linked to pivot tables and can dynamically
update as you change the pivot table data. This is helpful
for interactive data analysis.
How to Create:

First, create a Pivot Table.
Then, go to the PivotTable Analyze or Analyze tab and
select PivotChart.
Choose the chart type and format it as needed.

6. COMBO CHARTS
Combo charts allow you to combine two or more chart
types into one (e.g., a column and line chart). This is useful
when comparing different data sets with varying scales.
How to Create:

Select your data.
Go to Insert &gt; Combo Chart &gt; Custom
Combination
Choose the chart types for each data series.
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7. 3D CHARTS
3D charts can add depth to your data visualization,
but they should be used sparingly as they can
distort the data.
How to Create:

Choose a chart type, such as 3D Column or 3D
Surface, from the Insert tab &gt; 3D Chart..

8. USING THE DATA MODEL AND POWER PIVOT
For large datasets, Excel’s Power Pivot and Data Model
features allow you
to create more advanced and interactive visualizations.
How to Use:

Use Power Pivot to create a data model that combines
data from multiple sources.
Then, use Pivot Tables and Pivot Charts to visualize the
data.

Dashboards are comprehensive views of your data, often
combining multiple charts, pivot tables, and KPIs (Key
Performance Indicators) in one place.
 How to Create a Dashboard:

Organize your data and create various charts and
tables on asingle worksheet.
Use Slicers and Timelines to add interactivity and allow
users to filter the data.
Slicers: Go to Insert &gt; Slicer (for PivotTables or tables)
to filter data in your charts.
Timelines: Go to Insert &gt; Timeline (for time-based
data) to filter data by date.

9. DASHBOARDS
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A Pivot Table in Excel is a powerful tool that allows you to
summarize, analyze, and present large amounts of data in
a more readable and meaningful format. It helps to group
data, calculate totals, averages, and much more, without
the need for complex formulas.

PIVOT TABLES IN EXCEL

1. HOW TO CREATE A PIVOT TABLE
To create a Pivot Table in Excel, follow these steps:

Step-by-Step Guide to Creating a Pivot Table
1. Select Your Data:

Ensure your data is organized in columns with headers.
Each column should represent a field, and the first row
should containdescriptive headers 
(e.g.,&quot;Date,&quot;&quot;Sales,&quot;
&quot;Product,&quot; &quot;Region&quot;).

2. Insert a Pivot Table:
Go to the Insert tab in the Ribbon.
Click on PivotTable in the Tables group.
In the dialog box, Excel will automatically select the data
range (you can adjust it if necessary).
Choose where you want the Pivot Table to be placed
(either in a New Worksheet or an Existing Worksheet).

3. Set Up the Pivot Table:
Once the Pivot Table is created, a PivotTable Field List
will appear on the right side of the Excel window.
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You will see a list of fields (columns) from your original
data. Drag and drop these fields into the following
areas:

Rows: Used to group data (e.g., &quot;Region,&quot;
&quot;Product&quot;).

Columns: Used to display data across the top of the table
(e.g., &quot;Month,&quot; &quot;Year&quot;).

Values: Used for calculations, such as sum, count,
average, etc. (e.g., &quot;Sales&quot;).

Filters: Used to filter the data based on specific criteria
(e.g., &quot;Date,&quot; &quot;Salesperson&quot;).

Example:
If you want to summarize sales by product and region, you
would:

Drag Product to the Rows area.
Drag Region to the Columns area.
Drag Sales to the Values area (it will default to Sum).
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Once the Pivot Table is created, you can interact with it to
analyze your data more effectively. Here are some key
features and actions you can take to use your Pivot Table:

1. Grouping Data
 You can group data by date, number ranges, or text.

Group by Date: Right-click on a date field in the Pivot
Table, then select Group. You can group by months,
years, days, or quarters.
Group by Number: Right-click on a number field, choose
Group, and specify a range (e.g., group sales amounts
into ranges).
Group by Text: You can group categories of text, like
regions or products, into meaningful groups.

2. Sorting Data
Right-click on a row or column label in the Pivot Table and
choose Sort to sort the data in ascending or descending
order.

3. Filtering Data
You can apply filters to focus on specific subsets of data.
There are twoways to filter:

Using the Filter Area: Drag a field into the Filters area. For
example, you can drag Date or Product Category into
the Filters area to filter your Pivot Table by specific
dates or categories.
Using the Drop-down Menu: Click the drop-down arrow
next to row or column labels to filter the data.

2. HOW TO USE A PIVOT TABLE
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4. Refreshing Pivot Table Data
 If the data in your original table changes, the Pivot Table
needs to be updated to reflect those changes. To do this:

Right-click on the Pivot Table and select Refresh.
Alternatively, click on the PivotTable Analyze tab, and
click Refresh.

5. Formatting Pivot Table Data
You can format numbers or dates within a Pivot Table.
Right-click on the field you want to format, choose
Value Field Settings, and select the desired format.
You can also apply Conditional Formatting to highlight
values that meet specific criteria (e.g., sales greater
than $10,000).
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Data Validation in Excel allows you to control the type of
data entered into a cell, ensuring data integrity and
consistency. This is especially useful when you want to
restrict the kind of information users can enter (e.g., only
allowing numbers, dates, or specific choices).

Types of Data Validation:
Whole numbers or decimal numbers.
Dates (e.g., allowing only dates within a certain range).
Text length (limiting the number of characters in a cell).
List (allowing only pre-defined choices from a
dropdown).

How to Set Up Data Validation:
1. Select the cell or range of cells where you want to apply
the validation.

2. Go to the Data tab, and in the Data Tools group, click
Data Validation.

3. In the Data Validation dialog box, choose the type of
validation you want:

Under the Settings tab, select the validation criteria.
For whole numbers, choose &quot;Whole Number&quot;
and set the conditions (e.g., between 1 and 100).
For list values, choose &quot;List&quot; and enter the
allowed values (e.g., &quot;Yes, No, Maybe&quot;).

3. DATA VALIDATION 
(SETTING RULES FOR DATA INPUT)
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4. Optionally, you can also add an Input Message that
shows when the cell is selected (e.g., &quot;Enter a number
between 1 and 100&quot;).

5. Under the Error Alert tab, you can set a custom error
message that will appear if the user tries to enter invalid
data.

Example:

1. List Validation: To create a drop-down list for entering
status options(e.g., &quot;Pending,&quot;
&quot;Completed,&quot; &quot;In Progress&quot;):

Go to Data Validation &gt; Settings.
Select List in the Allow box.
In the Source field, type the items separated by
commas: Pending, Completed, In Progress.
Now, only those three options will be available in the cell
dropdown.

2. Number Range Validation: To restrict data entry to
whole numbers between 1 and 100:

Go to Data Validation &gt; Settings.
Select Whole Number in the Allow box.
Set the range to Between 1 and 100.
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A macro is a series of commands or actions that you can
record and save in Excel. Instead of performing these tasks
manually each time, you can run the macro to perform
them automatically. Macros can range from simple tasks
like formatting a worksheet to more complex automation,
such as running calculations or generating reports.

Before you can create or run macros, you need to enable
them:
1. Go to the &quot;File&quot; tab and click on Options.

2. In the Excel Options dialog box, click on Trust Centre and
then Trust Centre Settings.

3. Under Macro Settings, select Enable all macros and
ensure Trust access to the VBA project object model is
checked. This will allow you to create and run macros.

Note: Enabling macros can expose your system to potential
security risks, so it is important to only enable macros from
trusted sources.

Recording a Basic Macro
One of the easiest ways to create a macro is to record it.
When you record a macro, Excel tracks your actions and
generates the corresponding VBA code.
Here’s how to record a simple macro:

EXCEL MACROS
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Steps to Record a Macro:
1. Start Recording:

Go to the View tab on the Ribbon.
In the Macros group, click on Record Macro

Running a Recorded Macro
To run the macro you just recorded, follow these steps:
1. Go to the View tab.
2. In the Macros group, click Macros, then select View
Macros.
3. In the Macro Name list, select the macro you want to run.
4. Click Run.

Saving a Workbook with Macros
Excel workbooks containing macros must be saved as a
macro-enabled
workbook. Here’s how:
1. Go to File &gt; Save As.
2. Choose the location where you want to save the file.
3. Under Save as type, select Excel Macro-Enabled
Workbook (.xlsm).
4. Click Save

Security Considerations
Macro Security: Macros can potentially contain harmful
code, so always be cautious when opening workbooks
with macros from unknown sources. Excel has several
security levels to protect you from unsafe macros.

You can adjust your security settings for macros under File
> Options >Trust
Center > Trust Center Settings > Macro Settings.
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Excel offers a range of keyboard shortcuts and tips that can
greatly improve your productivity and efficiency when
working with spreadsheets. Whether you’re navigating
through large datasets, formatting cells, or performing
calculations, mastering these shortcuts can save you time
and effort. Here’s a comprehensive list of essential Excel
shortcuts and tips to boost your workflow:

1. Excel Navigation Shortcuts
Move between cells:

Arrow keys: Move one cell in the direction of the arrow.
Ctrl + Arrow key: Jump to the edge of the data region in
the direction of the arrow.
Home: Jump to the beginning of the current row.
Ctrl + Home: Jump to the top-left corner (A1) of the
worksheet.
Ctrl + End: Jump to the last used cell in the worksheet.

Switch between sheets:
Ctrl + Page Up: Move to the previous worksheet.
Ctrl + Page Down: Move to the next worksheet.

Jump to a specific cell:
Ctrl + G or F5: Open the &quot;Go To&quot; dialog box
to jump to a specificcell (e.g., A10, D25).

SHORTCUTS AND TIPS IN EXCEL
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2. Excel Selection Shortcuts

Select entire row or column:
Shift + Spacebar: Select the entire row of the active cell.
Ctrl + Spacebar: Select the entire column of the active
cell.

Select the entire worksheet:
Ctrl + A: Select the entire worksheet (pressing twice
selects all data, not just the empty rows or columns).

Extend selection:
 Shift + Arrow keys: Extend selection by one cell in the
direction of the arrow.
 Ctrl + Shift + Arrow keys: Extend selection to the edge of
the data region in the direction of the arrow.

3. Excel Data Entry Shortcuts

Fill data:
Ctrl + D: Fill the selected cell with the contents of the cell
above (down).
Ctrl + R: Fill the selected cell with the contents of the cell
to the left (right).

AutoFill:
Drag the fill handle: Use the small square at the
bottom-right corner of a cell to drag and auto-fill
values, dates, or patterns (e.g., days of the week,
numbers).
Ctrl + Shift + Arrow key: Select the whole range for
AutoFill, then press Ctrl + D or Ctrl + R.

Analytics Career Connect Wasim Patwari



Insert current date and time:
Ctrl + ;: Insert the current date in the active cell.
Ctrl + Shift + ;: Insert the current time in the active cell.

Fill in the formula bar:
Alt + E, S, V (after copying): Paste values only (useful when
you need to copy and paste without formatting).

4. Formatting Shortcuts
Bold, Italics, and Underline:

Ctrl + B: Apply or remove bold formatting.
Ctrl + I: Apply or remove italics.
Ctrl + U: Apply or remove underline.

Open Format Cells Dialog:
Ctrl + 1: Open the Format Cells dialog box where you can
change number formatting, fonts, alignment, borders, and
more.

 Format as currency:
Ctrl + Shift + $: Apply currency formatting to the selected
cells.

Format as percentage:
Ctrl + Shift + %: Apply percentage formatting to the selected
cells.

Format as number with two decimals:
Ctrl + Shift + !: Apply number formatting with two decimal
places.

Apply borders:
Ctrl + Alt + 0: Add borders to selected cells.
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5. Working with Formulas
Enter a formula:

 =: Start a formula in a cell (you must press = first to enter a
formula).
Alt + =: AutoSum (automatically inserts the SUM formula for
the selected range).

Show formulas in the worksheet:
Ctrl + ` (backtick): Toggle between displaying formula
results and the formulas themselves in the worksheet.

Absolute and relative references:
 F4: Toggle through absolute (e.g., $A$1), relative (e.g., A1),
and mixed references (e.g., $A1 or A$1) in formulas.

6. Excel Editing Shortcuts
 Undo and Redo:

Ctrl + Z: Undo the last action.
Ctrl + Y: Redo the last action.

Cut, Copy, Paste:
Ctrl + X: Cut selected data.
Ctrl + C: Copy selected data.
Ctrl + V: Paste copied or cut data.

Clear contents:
Delete: Clear the contents of the selected cell(s).
Alt + E, A, A: Clear all formatting (no data).

7. Excel File and Workbook Shortcuts
Create a new workbook:

Ctrl + N: Create a new Excel workbook.

Open an existing workbook:
Ctrl + O: Open an existing workbook.
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Save the workbook:
Ctrl + S: Save the current workbook.

Print the workbook:
Ctrl + P: Open the Print dialog.

 Close the workbook:
Ctrl + W: Close the current workbook.

8. Excel Miscellaneous Tips
Freeze Panes:

 Use View &gt; Freeze Panes to lock headers or columns in
place, allowing you to scroll without losing sight of key
information.

Split the window:
Alt + W, S: Split the Excel window into multiple panes for
viewing different parts of the worksheet at once.

AutoFilter:
 Ctrl + Shift + L: Apply or remove AutoFilters from the selected
data range. This is useful for quickly sorting or filtering data.

Hide/Unhide Rows or Columns:
Ctrl + 9: Hide the selected rows.
Ctrl + Shift + 9: Unhide hidden rows.
Ctrl + 0: Hide the selected columns.
Ctrl + Shift + 0: Unhide hidden columns.

Zoom In/Out:
Ctrl + Scroll Wheel: Zoom in or out in the worksheet using the
mouse scroll wheel while holding the Ctrl key.
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Insert a hyperlink:
Ctrl + K: Insert a hyperlink in the selected cell.

Convert text to columns:
Alt + A, E: Open the &quot;Text to Columns&quot; wizard to
split data in a single column into multiple columns (e.g., split
first and last names).

9. Advanced Excel Tips
Quick Access Toolbar: Customize the Quick Access Toolbar
for fast access to your most frequently used tools (e.g.,
Save, Undo, Redo).
Use Named Ranges: Assign a name to a range of cells to
make formulas easier to understand. Use the Name Box next
to the formula bar to define a name for the selected range.
Power Query: Use Power Query (available in Excel 2016 and
later) for advanced data cleaning and transformation
tasks.
Flash Fill: Automatically fill in values based on a pattern you
provide. For example, if you have a list of names, type the
first name and last name, and Excel will automatically fill in
the rest. Press Ctrl + E totrigger Flash Fill.
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Follow us for more

If you want to become a Data Analyst with the help of
free resources and without investing in expensive

courses, Connect With Us.

Internship Program : Get real-world experience through
hands-on projects, preparing you for the professional world.
Mentorship Program : Learn to upskill effectively with expert
guidance and personalized self-learning strategies
Job Assistance Program : Connect with top employers and
gain the tools to confidently secure your dream job.

Kickstart Your Data
Analytics Journey

Today!
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